OpenWrt settings for Century Link and Quantum Fiber

Hint: these are one and the same provider, just different authorization/authentication from user perspective. CL is/was using PPPoE, while Quantum is plain DHCP. Both are using VLAN 201 tagged traffic. Note in the examples below lan5 is the interface CL is connected.

config interface 'wan'
	option device 'br-wan.201'
	option proto 'pppoe'
	option username 'username@centurylink.net'
	option password 'password'
	option metric '100'

config device
	option type 'bridge'
	option name 'br-wan'
	list ports 'lan5'
	option mtu '1500'
	option txqueuelen '1000'
	option mtu6 '1500'
	option macaddr 'AA:BB:CC:DD:EE:FF'

config bridge-vlan
	option device 'br-wan'
	option vlan '201'
	list ports 'lan5:t'

Quantum Fiber Link to heading

config interface 'wan'
	option device 'br-wan.201'
	option proto 'dhcp'

config device
	option type 'bridge'
	option name 'br-wan'
	list ports 'lan5'
	option mtu '1500'
	option txqueuelen '1000'
	option mtu6 '1500'
	option macaddr 'AA:BB:CC:DD:EE:FF'

config bridge-vlan
	option device 'br-wan'
	option vlan '201'
	list ports 'lan5:t'